bekomme really-static nicht zum Laufen

bekomme really-static nicht zum Laufen

Postby ChristophK » Sat 29. Jun 2013, 09:16

Hi,

Ich wollte mal wordpress ausprobieren und zwar direkt mit deinem Plugin. Habe eine frische Wordpress Multisite Installation angelegt mit Subdomains. Die einzelenen wordpress seiten haben als URL dann <name>.wordpress.example.com.
Habe eine Wordpress Seite erstellt, eine Seite und Kommentar angelegt. Dann hab ich really-static aktiviert. Allerdings funktioniert das abgreifen der Seite laut really-static log nicht und man kann auch mit der normalen URL nicht mehr auf die Seiten zugreifen, es kommt eine Meldung, dass es die Seite nicht gibt. im Dashboard ist sie noch drinnen, auch nach deaktivieren des really-static plugins, gehen die Seiten nicht mehr. Der Log von really-static:

Code: Select all
Fileversion: April 20 2013 / 10:05:50
Relaseid: 0.520130415
Language: en_US
Wordpressversion: 3.5.2

CURL: available
file_get_contents: available
allow_url_fopen: active
Host-OS: Linux
home: http://test2.wordpress.example.com
site_url: http://test2.wordpress.example.com

Local: http://test2.wordpress.example.com/
Remote: http://example.com/test/

Local Design: http://test2.wordpress.example.com/wp-content/themes/twentytwelve/
Remote Design: http://test2.wordpress.example.com/wp-content/themes/twentytwelve/
Permastructure: /%year%/%monthnum%/%day%/%postname%/
Multisite: active
Multimainsite: deactive
Multisiteurl:http://test2.wordpress.example.com
Multidomain:test2.wordpress.example.com
Multipath:/
Plugins: Really Static (v0.31)
RSPlugins:
Last 40 Logfileentrys:
=====================
 29 Jun 2013 08:04:50: init defaults done
29 Jun 2013 08:04:48: init defaults
29 Jun 2013 08:04:48: init Database
29 Jun 2013 08:04:48: Init Really-static install
29 Jun 2013 08:04:48: rs_upgrade_real
29 Jun 2013 08:04:48: rs_upgrade
29 Jun 2013 08:04:48: rs_activation
29 Jun 2013 07:40:31: deinstallation done
29 Jun 2013 07:40:28: remove defaults
29 Jun 2013 07:40:28: remove Database
29 Jun 2013 07:40:28: Init Really-static deinstall
29 Jun 2013 07:40:28: rs_deactivation
29 Jun 2013 07:30:40: Getting a error (timeout, 403, 404 or 500 error ) while loading: http://test2.wordpress.example.com/sample-page/
29 Jun 2013 07:30:40: get http://test2.wordpress.example.com/sample-page/
29 Jun 2013 07:30:40: Getting a error (timeout, 403, 404 or 500 error ) while loading: http://test2.wordpress.example.com/pagetest/
29 Jun 2013 07:30:40: get http://test2.wordpress.example.com/pagetest/
29 Jun 2013 07:30:40: Getting a error (timeout, 403, 404 or 500 error ) while loading: http://test2.wordpress.example.com/2013/
29 Jun 2013 07:30:40: get http://test2.wordpress.example.com/2013/
29 Jun 2013 07:30:40: Getting a error (timeout, 403, 404 or 500 error ) while loading: http://test2.wordpress.example.com/2013/06/
29 Jun 2013 07:30:39: get http://test2.wordpress.example.com/2013/06/
29 Jun 2013 07:30:39: Getting a error (timeout, 403, 404 or 500 error ) while loading: http://test2.wordpress.example.com/2013/06/29/
29 Jun 2013 07:30:39: get http://test2.wordpress.example.com/2013/06/29/
29 Jun 2013 07:30:39: Getting a error (timeout, 403, 404 or 500 error ) while loading: http://test2.wordpress.example.com/category/uncategorized/
29 Jun 2013 07:30:39: get http://test2.wordpress.example.com/category/uncategorized/
29 Jun 2013 07:30:39: Getting a error (timeout, 403, 404 or 500 error ) while loading: http://test2.wordpress.example.com/author/admin/
29 Jun 2013 07:30:39: get http://test2.wordpress.example.com/author/admin/
29 Jun 2013 07:30:39: Getting a error (timeout, 403, 404 or 500 error ) while loading: http://test2.wordpress.example.com/2013/06/29/hello-world/
29 Jun 2013 07:30:38: get http://test2.wordpress.example.com/2013/06/29/hello-world/
29 Jun 2013 07:30:38: Cachehit: index.html @ 29.06.2013 07:10:23
29 Jun 2013 07:30:38: get http://test2.wordpress.example.com/
29 Jun 2013 07:30:38: Verbinde

)

        )
            [sample-page/index.html] => http://test2.wordpress.example.com/sample-page/
            [pagetest/index.html] => http://test2.wordpress.example.com/pagetest/
            [2013/index.html] => http://test2.wordpress.example.com/2013/
            [2013/06/index.html] => http://test2.wordpress.example.com/2013/06/
            [2013/06/29/index.html] => http://test2.wordpress.example.com/2013/06/29/

ChristophK
 

Re: bekomme really-static nicht zum Laufen

Postby MichaelL » Sat 29. Jun 2013, 16:08

Hallo,

ich habe in den letzten Tagen auch das gleiche probiert und habe genau das gleiche Problem. Sobald ich das really-static Plugin auf einer meiner Multi-Site Blogs aktiviere, funktionieren keine Untersteigen mehr (außer der Homepage, diese wird auch als static File exportiert).

Wenn ich das Plugin deaktiviere, bleibt es auch so, ich konnte es aber wieder zum Laufen bringen, indem ich kurz die Permalinks auf Standard gesetzt habe und dann anschließend wieder auf mein gewünschtes Format (post-name) zurückgesetzt habe, dann funktioniert es wieder (aber eben auch nur mit deaktiviertem Really-Static Plugin).

Es wäre super toll, wenn really-static auch auf Multi-Site Blogs funktionieren würde! :)
MichaelL
 
Posts: 3
Joined: Sat 29. Jun 2013, 16:04

Re: bekomme really-static nicht zum Laufen

Postby ChristophK » Sat 29. Jun 2013, 19:26

Bin ich wenigstens nicht der Einzige :-) Laut anderen läuft aber really-static mit mutli-site Installationen, eventuell ist das kürzliche 3.5.2 Update schuld.
BTW: Hab es mit der offizielen really-static version und der letzten dev Version (von der das log kam) probiert.
ChristophK
 

Re: bekomme really-static nicht zum Laufen

Postby ChristophK » Sat 29. Jun 2013, 22:04

Hi,

also hab ein paar Tests gemacht, der Multi Site Modus ist nicht schuld. Allerdings ändert der Multi Site Modus die "Permalink Settings" von "Default" zu "Day and name". Und genau dieser Modus funktioniert nicht mit really-static. Wenn man ihn auf "Default" stellt, geht really-static :-). Allerdings finde ich die "Day and name" Option viel schöner von der Links her, darum wäre es nicht schlecht wenn man das fixen kann :-).

Hab auch eine Single Installation mit "Day and name" Permalink Option probiert, geht auch nicht, gleicher Fehler wie bei der Mutli Site Installation.
ChristophK
 

Re: bekomme really-static nicht zum Laufen

Postby MichaelL » Sun 30. Jun 2013, 11:58

Hi,

ich habe es gerade mit der alten Wordpress Version 3.5.1 versucht, hatte aber das selbe Problem. Anschließend habe ich es als Single-Blog versucht und da hat es dann bei mir schon funktioniert, auch mit den umgestellten Permalinks. Sobald ich Multisite aktiviert habe, gingen die Unterblogs mit den geänderte Permalinks nicht mehr. Auf dem Hauptblog unter "/" hat es dann sogar funktioniert.

Vielleicht machen wir ja einfach irgendwas bei der Konfiguration falsch und es gibt einen Trick, wie man es zum Laufen bekommt. :D
MichaelL
 
Posts: 3
Joined: Sat 29. Jun 2013, 16:04

Re: bekomme really-static nicht zum Laufen

Postby MichaelL » Tue 2. Jul 2013, 11:59

Bei mir läuft es jetzt. Habe die Anleitung von http://www.php-welt.net/really-static/d ... ation.html nochmal gelesen und der entscheidende Punkt war dann 1. unter "wie geht's". Ich habe also unter den Siteeinstellungen die home URL auf eine andere geändert - ich denke Unterverzeichnis sollte gehen, ich habe es dann gleich mit einer Domain ausprobiert und anschließend die gesamte Konfiguration auf diese URL angepasst. Ich habe dann die ganze Site in static-Files exportiert mit "Alles neuschreiben" und das Resultat hatte die gewünschten Permalinks und war schön in lauter statischen html-Files. Hoffe, das hilft! :)
MichaelL
 
Posts: 3
Joined: Sat 29. Jun 2013, 16:04

Re: bekomme really-static nicht zum Laufen

Postby ChristophK » Thu 4. Jul 2013, 09:06

Aber bei einer Multisite Installation gibt es doch diese URL's nicht mehr zum einstellen?
ChristophK
 

Re: bekomme really-static nicht zum Laufen

Postby Erik Sefkow » Mon 8. Jul 2013, 09:41

@ChristophK eigentlich solllllte bei der really-static multisite installation auch alles automatisch funktionieren, dies ist aber eher mein Sorgenkind.
Bei Multisite kann man auch die Pfade manuell ändern, wenn du alls seitenadmin angemeldet bist folge folgendem Pfad:
seitenverwaltung.png
seitenverwaltung.png (30.2 KiB) Viewed 6103 times


Nachdem du auf bearbeiten geklickt hast gibt es einen reiter einstellungen, dort kannst du die einstellungen siteurl und home editeren
siteurl = deine Wordpressurl
home = wo really-static die dateien ablegt.

Dann würde ich nochmal mich auf der wordpresssubseite einloggen und dort einfach die permalink einstellungen neu speichern (veranlasst wordpress gecachte urls neu zu generieren)
Hoffe das hilft.
Wenn meine Zeit gerade nicht so arg knapp wäre, dann hätt ich das schon behoben.
Erik Sefkow
Administrator
 
Posts: 69
Joined: Sun 16. Sep 2012, 14:44


Return to deine Fragen


cron